const regex = /(?<!^|\w)\.|\.(?!\w|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!^|\\w)\\.|\\.(?!\\w|$)', 'g')
const str = `.Domain:...................google.com.`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);