re = /(?<!^|\w)\.|\.(?!\w|$)/
str = '.Domain:...................google.com.'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result