use strict;
my $str = '.Domain:...................google.com.';
my $regex = qr/(?<!^|\w)\.|\.(?!\w|$)/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";