#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Employee Table:(?:(?:\n(?!$))[^\n<]*)*"
Local $sString = "Employee Table:" & @CRLF & _
"Name Description Type" & @CRLF & _
"Bob Employee Standard" & @CRLF & _
"Jim Employee Standard" & @CRLF & _
"james Employee Standard" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Tools:" & @CRLF & _
"Item Serial Tag" & @CRLF & _
"Battery 0101 B." & @CRLF & _
"Drill 9292 D." & @CRLF & _
"Phone 8464 P." & @CRLF & _
"" & @CRLF & _
"Locations:" & @CRLF & _
"Station code len" & @CRLF & _
"West 12 9" & @CRLF & _
"North 1 9" & @CRLF & _
"East 21 9" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Employee Table:" & @CRLF & _
"Name Description Type" & @CRLF & _
"Bob Employee Standard" & @CRLF & _
"Jim Employee Standard" & @CRLF & _
"james Employee Standard" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Tools:" & @CRLF & _
"Item Serial Tag" & @CRLF & _
"Battery 0101 B." & @CRLF & _
"Drill 9292 D." & @CRLF & _
"Phone 8464 P." & @CRLF & _
"" & @CRLF & _
"Locations:" & @CRLF & _
"Station code len" & @CRLF & _
"West 12 9" & @CRLF & _
"North 1 9" & @CRLF & _
"East 21 9" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")