import re
regex = re.compile(r"Employee Table:(?:(?:\n(?!$))[^\n<]*)*", flags=re.MULTILINE)
test_str = ("Employee Table:\n"
"Name Description Type\n"
"Bob Employee Standard\n"
"Jim Employee Standard\n"
"james Employee Standard\n\n\n"
"Tools:\n"
"Item Serial Tag\n"
"Battery 0101 B.\n"
"Drill 9292 D.\n"
"Phone 8464 P.\n\n"
"Locations:\n"
"Station code len\n"
"West 12 9\n"
"North 1 9\n"
"East 21 9\n\n\n"
"Employee Table:\n"
"Name Description Type\n"
"Bob Employee Standard\n"
"Jim Employee Standard\n"
"james Employee Standard\n\n\n"
"Tools:\n"
"Item Serial Tag\n"
"Battery 0101 B.\n"
"Drill 9292 D.\n"
"Phone 8464 P.\n\n"
"Locations:\n"
"Station code len\n"
"West 12 9\n"
"North 1 9\n"
"East 21 9\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")