import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\",\\\")";
final String string = "{\"action\":\"add\",\"actions\":[{\"currency\",\"MYR\"}],\"ctx\":\"{\\\"charset\\\":\\\"UTF-8\\\",\\\"client_id\\\":\\\"G9.2.2045341156.1629864410\\\",\\\"cookie\\\":\\\"1\\\",\\\"domain_user\\\":\\\"28f51979-bef8-4731-b242-e3a00496d9ba\\\",\\\"fp\\\":\\\"659810303\\\",\\\"id\\\":\\\"d368f505-6226-4650-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}