# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\",\")"
test_str = "{\"action\":\"add\",\"actions\":[{\"currency\",\"MYR\"}],\"ctx\":\"{\\\"charset\\\":\\\"UTF-8\\\",\\\"client_id\\\":\\\"G9.2.2045341156.1629864410\\\",\\\"cookie\\\":\\\"1\\\",\\\"domain_user\\\":\\\"28f51979-bef8-4731-b242-e3a00496d9ba\\\",\\\"fp\\\":\\\"659810303\\\",\\\"id\\\":\\\"d368f505-6226-4650-"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.