re = /(\",\")/m
str = '{"action":"add","actions":[{"currency","MYR"}],"ctx":"{\\"charset\\":\\"UTF-8\\",\\"client_id\\":\\"G9.2.2045341156.1629864410\\",\\"cookie\\":\\"1\\",\\"domain_user\\":\\"28f51979-bef8-4731-b242-e3a00496d9ba\\",\\"fp\\":\\"659810303\\",\\"id\\":\\"d368f505-6226-4650-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end