using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w|(?<!\.)\.)+(?<!\.)\.(testnet|near)$";
string input = @"example.testnet
sub.ex.testnet
something.testnet
shouldnotendwithperiod.testnet.
space should fail.testnet
touchingDotsShouldfail..testnet
example.near
exa..ef.near";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}