re = /^(\w|(?<!\.)\.)+(?<!\.)\.(testnet|near)$/m
str = 'example.testnet
sub.ex.testnet
something.testnet
shouldnotendwithperiod.testnet.
space should fail.testnet
touchingDotsShouldfail..testnet
example.near
exa..ef.near'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end