const regex = /[0-9]+_[0-9a-z_-]+_p\.dat/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]+_[0-9a-z_-]+_p\\.dat', 'gm')
const str = `40_20200313_0cd6963f-bf5b-4eb0-b310-255a23ed778e_p.dat`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}