$re = '/[0-9]+_[0-9a-z_-]+_p\.dat/m';
$str = '40_20200313_0cd6963f-bf5b-4eb0-b310-255a23ed778e_p.dat';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);