// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-9]+_[0-9a-z_-]+_p\.dat").unwrap();
let string = "40_20200313_0cd6963f-bf5b-4eb0-b310-255a23ed778e_p.dat";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}