using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\s*[#])\S.*";
string input = @"#Use '#' for commenting hosts
ibin-dev-build
#ibin-dev1
# ibin-dev2
ibin-bdl-adapter
#ibin-elk
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}