re = /^(?!\s*[#])\S.*/m
str = '#Use \'#\' for commenting hosts
ibin-dev-build
#ibin-dev1
# ibin-dev2
ibin-bdl-adapter
#ibin-elk
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end