package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]{5})[0-9]*`)
var str = `123456789`
var substitution = "$1****"
fmt.Println(re.ReplaceAllString(str, substitution))
}