$re = '/([0-9]{5})[0-9]*/m';
$str = '123456789';
$subst = "$1****";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;