using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"kiss(?!ing)|(?<!give)hug|(?<!my)love(?!ly)";
string input = @"love
mickmackusa
kisses
mylovely
give
hug
givehug
kiss
kissing";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}