$re = '/kiss(?!ing)|(?<!give)hug|(?<!my)love(?!ly)/i';
$str = 'love
mickmackusa
kisses
mylovely
give
hug
givehug
kiss
kissing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);