re = /kiss(?!ing)|(?<!give)hug|(?<!my)love(?!ly)/i
str = 'love
mickmackusa
kisses
mylovely
give
hug
givehug
kiss
kissing'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end