using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|(?<=[^.?\/[:alnum:]]))#+([\w\-]+)";
string input = @" #cli
#cli,
#clocks
#clocks,
#clocksnotes
#clocksnotes,
#clockstxt
#clockstxt,
[""blablabla#querytip""](https://twitter.com...
[""#querytip""](https://twitter.com...
#I'm
###multiple_pound_signs!";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}