import re
regex = re.compile(r"(?<=^|(?<=[^.?\/[:alnum:]]))#+([\w\-]+)")
test_str = (" #cli\n"
" #cli,\n"
" #clocks\n"
" #clocks,\n"
" #clocksnotes\n"
" #clocksnotes,\n"
" #clockstxt\n"
" #clockstxt,\n\n"
"[\"blablabla#querytip\"](https://twitter.com...\n\n"
"[\"#querytip\"](https://twitter.com...\n\n"
"#I'm\n\n"
"###multiple_pound_signs!")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")