re = /(?<=^|(?<=[^.?\/[:alnum:]]))#+([\w\-]+)/
str = ' #cli
#cli,
#clocks
#clocks,
#clocksnotes
#clocksnotes,
#clockstxt
#clockstxt,
["blablabla#querytip"](https://twitter.com...
["#querytip"](https://twitter.com...
#I\'m
###multiple_pound_signs!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end