#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\s|^)(?<!`)(#+[^#\s.,\/!$%\^&\*;:{}\[\]'"=`~()]+)"
Local $sString = " #cli" & @CRLF & _
" #cli," & @CRLF & _
" #clocks" & @CRLF & _
" #clocks, " & @CRLF & _
" #clocksnotes" & @CRLF & _
" #clocksnotes," & @CRLF & _
" #clockstxt" & @CRLF & _
" #clockstxt," & @CRLF & _
"" & @CRLF & _
"["blablabla#querytip"](https://twitter.com..." & @CRLF & _
"" & @CRLF & _
"```#this is a #cool script```" & @CRLF & _
"" & @CRLF & _
"["#querytip"](https://twitter.com..." & @CRLF & _
"" & @CRLF & _
"##AI #world-domination, #tag.;: #plankonformität #hello_world" & @CRLF & _
"" & @CRLF & _
"<!-- #I'm -->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")