using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s|^)(?<!`)(#+[^#\s.,\/!$%\^&\*;:{}\[\]'""=`~()]+)";
string input = @" #cli
#cli,
#clocks
#clocks,
#clocksnotes
#clocksnotes,
#clockstxt
#clockstxt,
[""blablabla#querytip""](https://twitter.com...
```#this is a #cool script```
[""#querytip""](https://twitter.com...
##AI #world-domination, #tag.;: #plankonformität #hello_world
<!-- #I'm -->";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}