$re = '/(?<=\s|^)(?<!`)(#+[^#\s.,\/!$%\^&\*;:{}\[\]\'"=`~()]+)/';
$str = ' #cli
#cli,
#clocks
#clocks,
#clocksnotes
#clocksnotes,
#clockstxt
#clockstxt,
["blablabla#querytip"](https://twitter.com...
```#this is a #cool script```
["#querytip"](https://twitter.com...
##AI #world-domination, #tag.;: #plankonformität #hello_world
<!-- #I\'m -->';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);