package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\w+([\.-]?\w+)*@\w+([\.-]?\w+)*(\.\w{2,63})+$`)
var str = `s.devries@ccvshop.nl`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}