$re = '/^\w+([\.-]?\w+)*@\w+([\.-]?\w+)*(\.\w{2,63})+$/';
$str = 's.devries@ccvshop.nl';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);