re = /^\w+([\.-]?\w+)*@\w+([\.-]?\w+)*(\.\w{2,63})+$/
str = 's.devries@ccvshop.nl'
# Print the match result
str.match(re) do |match|
puts match.to_s
end