using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w$]*[\w\d$]*?(\(\)|\(\g<0>\))?\.?)*";
string input = @"apple.orange.potatoe($apple.porage.pie)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}