re = /([\w$]*[\w\d$]*?(\(\)|\(\g<0>\))?\.?)*/
str = 'apple.orange.potatoe($apple.porage.pie)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end