package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\w$]*[\w\d$]*?(\(\)|\(\g<0>\))?\.?)*`)
var str = `apple.orange.potatoe($apple.porage.pie)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}