import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)-(.+:\\/\\/.+(?:[.:].+)+(?:\\/))?([\\w.-]+)\\/([\\w.-]+)@(.+)";
final String string = "protobuf-protocolbuffers/protobuf@v3.15.2\n"
+ "mongodb-https://github.com/mongodb/mongo-php-driver@v1.9\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}