$re = '/(\w+)-(.+:\/\/.+(?:[.:].+)+(?:\/))?([\w.-]+)\/([\w.-]+)@(.+)/m';
$str = 'protobuf-protocolbuffers/protobuf@v3.15.2
mongodb-https://github.com/mongodb/mongo-php-driver@v1.9
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);