using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"E:\\Software\\Download\\?(?!.*?\\).*$";
string input = @"E:\Software\Download\MSEdgeDL\miui_BOMB_21.1.28_f15be071ad_11.0
E:\Software\Download\MSEdgeDL
E:\Software\Download\";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}