use strict;
my $str = 'E:\\Software\\Download\\MSEdgeDL\\miui_BOMB_21.1.28_f15be071ad_11.0
E:\\Software\\Download\\MSEdgeDL
E:\\Software\\Download\\';
my $regex = qr/E:\\Software\\Download\\?(?!.*?\\).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}