const regex = /E:\\Software\\Download\\?(?!.*?\\).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('E:\\\\Software\\\\Download\\\\?(?!.*?\\\\).*$', 'gm')
const str = `E:\\Software\\Download\\MSEdgeDL\\miui_BOMB_21.1.28_f15be071ad_11.0
E:\\Software\\Download\\MSEdgeDL
E:\\Software\\Download\\`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}