using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\)""";
string input = @"Meine_kleine_Farm
MEINE ""KLEINE"" FARM
Meine kleine ""Farm""
Korrekt \""escaped\"" hier
halb ""korrekt\"" escaped
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}