re = /(?<!\\)"/
str = 'Meine_kleine_Farm
MEINE "KLEINE" FARM
Meine kleine "Farm"
Korrekt \\"escaped\\" hier
halb "korrekt\\" escaped
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end