#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?!\w*?(\w)\1)[word]+\b"
Local $sString = "word" & @CRLF & _
"wrd" & @CRLF & _
"drow" & @CRLF & _
"word word" & @CRLF & _
"worod" & @CRLF & _
"woord" & @CRLF & _
"wword" & @CRLF & _
"wordd" & @CRLF & _
"words" & @CRLF & _
"sword" & @CRLF & _
"wosrd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")