$re = '/\b(?!\w*?(\w)\1)[word]+\b/m';
$str = 'word
wrd
drow
word word
worod
woord
wword
wordd
words
sword
wosrd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);