import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!\\w*?(\\w)\\1)[word]+\\b";
final String string = "word\n"
+ "wrd\n"
+ "drow\n"
+ "word word\n"
+ "worod\n"
+ "woord\n"
+ "wword\n"
+ "wordd\n"
+ "words\n"
+ "sword\n"
+ "wosrd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}