#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^:\s]++)(?!:)"
Local $sString = "1 : A" & @CRLF & _
"2 : B" & @CRLF & _
"3 : C" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"3" & @CRLF & _
"1:A" & @CRLF & _
"11:A"
Local $sSubst = "Line:$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)