# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^:\s]++)(?!:)"
test_str = ("1 : A\n"
"2 : B\n"
"3 : C\n"
"1\n"
"2\n"
"3\n"
"1:A\n"
"11:A")
subst = "Line:$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.