import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^:\\s]++)(?!:)";
final String string = "1 : A\n"
+ "2 : B\n"
+ "3 : C\n"
+ "1\n"
+ "2\n"
+ "3\n"
+ "1:A\n"
+ "11:A";
final String subst = "Line:$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}