import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^fix(?:es)?(?:\\s+bugzilla)(?:\\s+(?:issues?|bugs?))?\\s+(#?\\d+(?:[\\s,\\+&and]+#?\\d+)*))|\n"
+ "(?:bugzilla\\s+(?:(?:issues?|bugs?)\\s+)?(#?\\d+(?:[\\s,\\+&and]+#?\\d+)*))";
final String string = "Fix bugzilla issue 12564: add std.range.walkBack ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}