import re
regex = re.compile(r"^(?<n>(?:@(?<org>[a-z0-9-~][a-z0-9-._~]*)\/)?(?<pkg>[a-z0-9-~][a-z0-9-._~]*))(?:@(?<v>[-a-z0-9><=_.^~*| ]+))?(?<p>\/[^\r\n]*)?$", flags=re.MULTILINE)
test_str = ("react-icons@4.4.0/\n"
"@heroicons/react@latest/package.json\n"
"react\n"
"react/hello\n"
"react@1\n"
"react/\n"
"reaction@1.1.1/index.js\n"
"react@*\n"
"react@>1.2|| <= 1.*\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")