using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?>\\caption(?:of)?\b[^{]*{|(?<!^)\G)(?>[^}{]|(\{(?:[^}{]*+|(?-1))*}))*?\K\\{2}";
string substitution = @"\\par";
string input = @" \begin{figure}
\includegraphics{pic.pdf}
\caption[]{My caption \\
Source: XYZ}
\label{fig:pic_1}
\end{figure}
\begin{figure}[H]
\includegraphics{pic.pdf}
\captionof[]{My caption \\ xyz \\ abc
\label{fig:pic_1} }
\end{figure}
\begin{figure}[H]
\includegraphics{pic.pdf}
\caption[]{My caption {with extra brackets}
Source: XYZ}
\label{fig:pic_1}
\end{figure}
\begin{figure}[H]
\includegraphics{pic.pdf}
\caption[]{My caption}
\end{figure}
Some text\\ %% This \\ should not be changed, it's not within a caption
More text
\begin{figure}[H]
\includegraphics{pic.pdf}
\caption[]{My caption \\ Source: XYZ}
\label{fig:pic_1}
\end{figure}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}