use strict;
my $str = ' \\begin{figure}
\\includegraphics{pic.pdf}
\\caption[]{My caption \\\\
Source: XYZ}
\\label{fig:pic_1}
\\end{figure}
\\begin{figure}[H]
\\includegraphics{pic.pdf}
\\captionof[]{My caption \\\\ xyz \\\\ abc
\\label{fig:pic_1} }
\\end{figure}
\\begin{figure}[H]
\\includegraphics{pic.pdf}
\\caption[]{My caption {with extra brackets}
Source: XYZ}
\\label{fig:pic_1}
\\end{figure}
\\begin{figure}[H]
\\includegraphics{pic.pdf}
\\caption[]{My caption}
\\end{figure}
Some text\\\\ %% This \\\\ should not be changed, it\'s not within a caption
More text
\\begin{figure}[H]
\\includegraphics{pic.pdf}
\\caption[]{My caption \\\\ Source: XYZ}
\\label{fig:pic_1}
\\end{figure}';
my $regex = qr/(?>\\caption(?:of)?\b[^{]*{|(?<!^)\G)(?>[^}{]|(\{(?:[^}{]*+|(?-1))*}))*?\K\\{2}/p;
my $subst = '\\\\par';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";