package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\/(.+?)\.\w+\/`)
var str = `http://autoit.script.com
http://autoit-script.com
http://autoitscript.com
http://autoit%20script.com
http://autoit_script.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}